Old versions of Overseer

Posted on May 11th, 2011

Occasionally┬áI’ll get an Email from an old Overseer customer that is currently licensed for Overseer 3.0, wondering why their keys do not work with the current Overseer 4.x version they download from the website. This is because there is an upgrade fee for major revision changes. This happens every few years, and all customers are free to continue using their older version with their older key– but at the price point that Overseer is sold at, free updates forever are not a reasonable option. I always offer a discount for upgrading from the past major revision(i.e. 3.x->4.x), and depending on time frame, sometimes the version before. This pricing is available at the bottom of our pricing page.

For those of you who would like to continue to use Overseer 3.0 and don’t have the last version, the installer is available here:

http://overseer-network-monitor.com/Downloads/Overseer3.exe