Updated to use v3.5 of the .NET Framework

Posted on July 30th, 2012

Overseer 5.0 now uses a newer version of the .NET Framework, 3.5. Overseer 4.x used .NET Framework 2.x for backwards-compatibility with Windows 2000. However, Windows 2008R2 introduced some new event log types that used a new API that was only available in .NET 3.5. Considering this limitation, I was forced to upgrade to .NET 3.5 to satisfy the demand for this new feature. Sadly, this makes Overseer 5.x incompatible with Windows 2000. Overseer can still monitor Windows 2000 computers, but Overseer itself cannot run on Windows 2000.¬†Windows 2000 is far past Microsoft’s extended support life cycles, so hopefully this won’t inconvenience too many– particularly since Overseer can still monitor Windows 2000 computers. For those that need Windows 2000 compatibility, we will still sell Overseer 4.x as well.